ZIP Container Format Ruby Library


Robert Haines



Source code


BSD (See Licence file or


© 2013-2015 The University of Manchester, UK

Gem Version Build Status Coverage Status


This is a Ruby library for working with ZIP Container files. See the ODF and UDF specifications for more details.

We follow the principles of Semantic Versioning for our releases.

Backwards incompatibility warnings!


The ZipContainer::Container class is now a common superclass of ZipContainer::Dir and ZipContainer::File. You can use ZipContainer::File as a direct replacement for ZipContainer::Container as the functionality is preserved. The new names bring this API into closer alignment with the underlying rubyzip API (Zip::File) and allows this library to work with “exploded” or unpacked containers directly.

ZipContainer::Container should not be used directly from version 2.0.0 onwards.


This class has been renamed in version 3.0.0. It is now simply called Error so that it’s fully qualified name is the more sensible ZipContainer::Error.


Version 1.0.0 and up of this gem uses version 1.0.0 and up of the rubyzip library. This has a backwards incompatible API that may clash with other gems that you are using. Please see the important note in the rubyzip readme for a workaround.


This library has two entry points.

The main ZipContainer::File class largely mimics the rubyzip Zip::File and Zip::FileSystem APIs so much of what you can do with them are supported for ZIP Containers. There is also API documentation with much more detail and any differences explained.

The ZipContainer::Dir class mimics, where possible, the core ruby Dir API.

There are some examples of how to use the library provided in the examples directory. See the contents of the tests directory for even more.

What this library can not do yet

The basic requirements of a ZIP Container are all implemented but memory resident ZIP Container files are not yet supported. Presently all operations are performed on files that are resident on disk.